スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

MacでSubversive

まっさらなMacにEclipse+Subversive環境を作ろうとして、とても苦労したのでメモ。

参考:
http://d.hatena.ne.jp/masatomix/20090303/1236048339
http://d.hatena.ne.jp/tilfin/20080627/1214568202
http://319ring.net/blog/archives/826
http://d.hatena.ne.jp/rmiya/20091004/1254651905


■結論(何をインストールしたか)
http://ecliplse.svnkit.com/1.3x/
・Core SVNKit Library (required)
-> SVNKit Library

http://community.polarion.com/projects/subversive/download/eclipse/2.0/update-site/
・Subversive SVN Connectors
-> Subversive SVN Connectors
-> Native JavaHL 1.5 Implementation (Optional)
-> SVNKit 1.2.2 Implementation (Optional)

http://download.eclipse.org/technology/subversive/0.7/update-site/
・Subversive Integration Plug-in's (Incubation)
-> Subversion SVN Integration for the Mylyn Project (Optional) (Incubation)
・Subversive SVN Team Provider (Incubation)


大まかな説明は、参考サイト様を参考にしてもらうとして、何に困ったか?どうやって解決したか。を書いていく。

・パッケージの依存関係がある?!
 SVNKitを入れる前にSVN Connectorを入れなきゃいけないだの(逆かな?笑)
 SVNKit x.x.x implementationを入れる前に、Native JavaHL y.y.y Implementationを入れなきゃいけないだの
 (これは、エラーメッセージを見ればなんとなくわかる)

・SVN Connectorがインストールされていない?!
 Subversive SVN Connectorsをインストールしただけでは、SVNリポジトリへのアクセスができない。
 SVN Repositoriesビューで、リポジトリを登録しようとしてもエラーが出る。
 (ちゃんとエラーメッセージ(コネクタがインストールされていません。インストールしているなら、Preferences -> Team -> SVN のSVNコネクタに登録してください。みたいな)が出るんだけど、そのときはさっぱりわからなかった。
 だって、Connectorインストールしたもん!なのに、SVNコネクタに登録するものの選択肢がないんだもの!とか思ったね)
 上述のSVNKit x.x.x Implementationがコネクタの本体(実装っていってるくらいだしねぇ…)なので、こいつを入れないといけなかったようです。

ちなみにSVNKit 1.1.7はJavaHL 1.4。SVNKit1.2.2はJavaHL 1.5。SVNKit 1.3.0はJavaHL 1.5。をそれぞれ一緒にインストールしないと怒られる。

最終的にはこんな感じ。(1回インストールしたあとだから、警告とか出てる)
Mac+Subversive item

テーマ : Mac
ジャンル : コンピュータ

コメントの投稿

管理者にだけ表示を許可する

プロフィール

森嶋晃介

Author:森嶋晃介
社会人2年目。
独学する勉強のために、いろいろ手を出して、それについて書いていく予定です。
今年こそ、たくさん書くぞ

最新記事
最新コメント
最新トラックバック
月別アーカイブ
カテゴリ
検索フォーム
RSSリンクの表示
リンク
ブロとも申請フォーム

この人とブロともになる

QRコード
QRコード
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。